London Mutual Credit Union - Online Application Forms Unavailable – Incident details

All systems operational

Online Application Forms Unavailable

Resolved
Operational
Started 23 days agoLasted about 19 hours

Affected

Loan & Membership Application Processing

Major outage from 1:05 PM to 7:47 AM

Websites

Degraded performance from 1:05 PM to 7:47 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Due to a data centre connectivity issue, our online loan application, membership application and contact detail update forms are currently unavailable. You will be unable to apply for a loan, membership or update your contact details via these forms until this issue is resolved.

    We are working to urgently resolve this issue, and will update you here as soon as it is fixed.