London Mutual Credit Union - Online Banking and SMS – Incident details

All systems operational

Online Banking and SMS

Resolved
Operational
Started about 1 month agoLasted 29 days

Affected

Mobile App
Online Banking
SMS Services
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We experienced an issue on 17.11.2024 which resulted in outdated SMS’ being sent out to our Members. We apologise for any inconvenience and confusion caused by the messages sent between 6-7am on Sunday 17th November.


    We are currently investigating an issue relating to our online and mobile banking services.  Our online and mobile services are temporarily unavailable but you will be able to card payments as usual.  We’re expecting to have this issue resolved by 2pm on Sunday 17th November.