London Mutual Credit Union - Issue with outward payments – Incident details

All systems operational

Issue with outward payments

Resolved
Operational
Started about 1 year agoLasted 35 minutes

Affected

Payments & Transfers

Operational from 2:55 PM to 3:30 PM

Mobile App

Operational from 2:55 PM to 3:30 PM

Online Banking

Operational from 2:55 PM to 3:30 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.