London Mutual Credit Union - Temporary Disruption to Helpdesk, Branch Services and Card Payments – Incident details

All systems operational

Temporary Disruption to Helpdesk, Branch Services and Card Payments

Resolved
Operational
Started about 2 hours agoLasted about 2 hours

Affected

Loan & Membership Application Processing

Operational from 8:47 AM to 11:02 AM

Payments & Transfers

Major outage from 8:47 AM to 10:49 AM, Degraded performance from 10:49 AM to 11:02 AM

Card Transactions

Operational from 8:47 AM to 11:02 AM

Websites

Operational from 8:47 AM to 11:02 AM

Mobile App

Major outage from 8:47 AM to 10:49 AM, Degraded performance from 10:49 AM to 11:02 AM

Online Banking

Major outage from 8:47 AM to 10:49 AM, Degraded performance from 10:49 AM to 11:02 AM

Updates
  • Update
    UTC
    Update
    This incident has been resolved.
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    We’re pleased to confirm that the main banking system issue has now been resolved.

    However, transfers to external bank accounts via Online Banking and an intermittent issue relating to card transactions are still affected.

    Please do not process the online transfers as yet until the issue is fully resolved.

    Our teams are working to resolve this as soon as possible.

  • Investigating
    UTC
    Investigating

    We’re currently experiencing a technical issue affecting our main banking system, which is currently down. This may impact card transactions and our online banking systems.

    Our Mobile Banking App and access to Online Banking have been frozen until the issue is resolved.

    You can still call us or visit a branch, but it is possible that our team will be unable to help for now and may ask you to call back later. Branches can also pay out up to £50 in cash.

    We apologise for the disruption today and thank you for your patience. We will continue to post updates here, including when the issue is resolved.