London Mutual Credit Union - Delays in Processing Payments & Transfers – Incident details

All systems operational

Delays in Processing Payments & Transfers

Resolved
Major outage
Started 29 days agoLasted 3 days

Affected

Payments & Transfers

Major outage from 3:00 PM to 1:51 PM, Operational from 1:51 PM to 3:28 PM, Degraded performance from 3:28 PM to 3:30 AM

Mobile App

Degraded performance from 3:00 PM to 1:51 PM, Operational from 1:51 PM to 3:30 AM

Online Banking

Degraded performance from 3:00 PM to 1:51 PM, Operational from 1:51 PM to 3:30 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved, and all outstanding payments have now been processed. If you have any questions about your account or are still having problems, please contact us so that we can investigate and resolve these for you. Thank you again for your patience and we apologise for the disruption over these past few days.

  • Monitoring
    Monitoring

    A small number of payments made during the outage are still queued and have not yet been processed. This is now being worked through overnight, and we expect all outstanding payments to be completed by tomorrow, Friday 3 April. Once processed, incoming payments will appear in your account and outgoing payments will reach their intended recipient.

    We will update here once this is complete.

    We apologise again for the disruption and inconvenience this incident has caused.

  • Resolved
    Resolved

    The payment issue affecting current accounts has now been resolved. New payments should process as usual, typically within a few minutes.

    If you made or received a payment during the outage, it may still be queued for processing. We are working through the backlog and all outstanding payments will be completed within the next hour or two.

    We are sorry for the disruption this has caused. Thank you for your patience.

  • Investigating
    Investigating

    We are aware of a problem that is causing delays with payments on your account. Money coming in may take longer to arrive than usual, and money you have sent to others may also be delayed.

    We are working to fix this and expect to have it sorted today. When it is fixed, all payments will go through automatically — so please do not try to make the same payment twice, as this could result in you being charged twice.

    We are sorry for any worry this has caused and will update you here as soon as the problem is fixed. Thank you for your patience.