London Mutual Credit Union - Service Notice: Helpdesk Line 02037731751 – Incident details

All systems operational

Service Notice: Helpdesk Line 02037731751

Resolved
Operational
Started 4 months agoLasted about 18 hours
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Our main line number 02037731751 is now working. However, there may still be occasional outages until the issue is fully resolved by Amazon Web Services (AWS). We continue to monitor the situation closely.

    In the meantime, if you experience any difficulty reaching us by phone, please email us at help@creditunion.co.uk or send a secure message via Online Banking, and we will respond to your enquiry as quickly as possible.

    We apologise for any inconvenience and appreciate your patience.