All systems operational

Planned Faster Payment and Online Banking Downtime

Completed
Scheduled for 27 Jul, 2022 at 09:00 – 10:00

Affects

Payments & Transfers
Mobile App
Online Banking
Updates
  • Completed
    27 Jul, 2022 at 10:00
    Completed
    27 Jul, 2022 at 10:00

    Maintenance has completed successfully

  • In progress
    27 Jul, 2022 at 09:00
    In progress
    27 Jul, 2022 at 09:00

    Maintenance is now in progress

  • Planned
    27 Jul, 2022 at 09:00
    Planned
    27 Jul, 2022 at 09:00

    Online and Mobile banking services will be disrupted from 10:00-11:00am due to essential maintenance work. During this time, there will also be disruption to payments/transfers. We apologize in advance for any inconvenience this may cause.