All systems operational

Online Banking Downtime

Completed
Scheduled for 13 Jul, 2022 at 16:00 – 16:30

Affects

Mobile App
Online Banking
Updates
  • Completed
    13 Jul, 2022 at 16:30
    Completed
    13 Jul, 2022 at 16:30

    Maintenance has completed successfully

  • In progress
    13 Jul, 2022 at 16:00
    In progress
    13 Jul, 2022 at 16:00

    Maintenance is now in progress

  • Planned
    13 Jul, 2022 at 16:00
    Planned
    13 Jul, 2022 at 16:00

    Online and Mobile banking services will be disrupted from 5:00-5:30pm today due to essential maintenance work. We apologize in advance for any inconvenience this may cause.