London Mutual Credit Union - Walworth Road Branch - Closure Today – Incident details
All systems operational
Walworth Road Branch - Closure Today
Resolved
Major outage
Started over 2 years agoLasted 4 days
Affected
Walworth Road Branch
Major outage from 7:14 AM to 7:46 AM
Updates
Resolved
Resolved
Our Walworth Road branch is back open today as usual.
Monitoring
Monitoring
Due to staff illness, our Walworth Road branch remains closed until further notice. Sorry for any inconvenience caused.
Identified
Identified
We are sorry to announce that our branch at Walworth Road will be closed today. This is due to a shortage of staff due to illness. We hope to re-open on Friday, and will post an update here when this issue is resolved.