London Mutual Credit Union - Lost & Stolen Debit Card Telephone Support - Temporary Outage – Incident details

All systems operational

Lost & Stolen Debit Card Telephone Support - Temporary Outage

Resolved
Operational
Started about 2 months agoLasted 2 days

Affected

Payments & Transfers

Degraded performance from 10:15 PM to 1:01 AM, Operational from 1:01 AM to 9:40 AM, Degraded performance from 9:40 AM to 9:02 AM

Phone Support

Partial outage from 10:15 PM to 1:01 AM, Operational from 1:01 AM to 9:40 AM, Partial outage from 9:40 AM to 9:02 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    Card services, including our Lost & Stolen helpline are now available on a temporary phone line.

    Please use the following number if your card is lost or stolen - 0121 726 4747 - until this incident is resolved.

  • Identified
    Identified

    Disruption to the lost & stolen card service is continuing. We are working closely with our card services provider to urgently restore this service, and will update here with more information as it becomes available.

    If your card is lost or stolen and you are unable to get through by phone, please email help@creditunion.co.uk to let us know, as well as trying to again once phone services are restored.

  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Telephone support for Lost & Stolen debit cards is currently unavailable due to a service problem with our card supplier.

    We are in contact with them to urgent;y clarify the situation and to ensure this service is back up and running as quickly as possible. We will update here with more information as soon as we receive it, as well as once the issue is resolved.

    If your card is lost or stolen while phone lines are down, please email help@creditunion.co.uk in addition to attempting to call back once the phone service is restored.

    Thank you for your patience, and we apologise for any difficulties this may cause you.