London Mutual Credit Union - Temporary Disruption to Helpdesk and Branch Services – Incident details

All systems operational

Temporary Disruption to Helpdesk and Branch Services

Resolved
Operational
Started 3 months agoLasted 3 days

Affected

Payments & Transfers

Operational from 12:17 PM to 2:50 PM, Degraded performance from 2:50 PM to 8:00 AM

Phone Support

Degraded performance from 12:17 PM to 8:00 AM

Email Support

Degraded performance from 12:17 PM to 8:00 AM

Walworth Road Branch

Degraded performance from 12:17 PM to 8:00 AM

Peckham Branch (Heaton Road)

Degraded performance from 12:17 PM to 8:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    We are continuing to work hard to resolve this IT issue, which is taking longer than expected. Unfortunately, we are now not expecting to be able to restore all systems before the end of today.

    Members who visit our branches today can withdraw up to a maximum of £50 in cash. This limit is due to counter staff being unable to access certain systems. Funds withdrawn in this way will be debited from your account on Monday.

    Debit cards are unaffected, and you can continue to use these to make purchases and to withdraw cash from cash machines as normal and throughout the weekend.

    We apologise for the significant disruption today, and for the inconvenience this may cause to your weekend.

  • Identified
    Identified

    Due to an IT server issue, our phone helpdesk and counter teams are currently unable to assist with certain types of account-related queries, including requests for help with unblocking access to online banking.

    You can still call us or visit a branch, but it is possible that our team will be unable to help for now, and will ask you to call back later. Following a short outage this morning, our online banking and mobile app are functioning normally.

    We apologise for the disruption today, and thank you for your patience. We will continue to post updates here, including when the issue is resolved.