London Mutual Credit Union - Online Banking & Mobile App Temporarily Unavailable – Incident details

All systems operational

Online Banking & Mobile App Temporarily Unavailable

Resolved
Major outage
Started 3 months agoLasted 18 minutes

Affected

Mobile App

Major outage from 8:39 AM to 8:57 AM

Online Banking

Major outage from 8:39 AM to 8:57 AM

Updates
  • Resolved
    Resolved

    This incident has now been resolved. You should be able to log into the mobile app using your existing login details. Please get in touch if you continue to have problems logging in.

  • Identified
    Identified

    We are experiencing a temporary technical issue with our mobile app and online banking service this morning. Users attempting to log into these services this morning may see a message indicating that their account has been 'blocked', even after correct login details have been entered.

    This message is incorrect. You do not need to reset your login or contact us to unblock your account.

    We are working to restore this service in the next 2-3 hours. Once systems are restored, you will be able to login as usual using your existing login details.

    Thank you for your patience and support and we apologise for the inconvenience this may cause you. We will update again here when systems are restored.