Payments & Transfers experiencing partial outage

Temporary Branch Closure & Limited Helpdesk Availability

Resolved
Major outage
Started 18 days ago Lasted about 2 hours

Affected

Phone Support
Walworth Road Branch
Peckham Branch (Heaton Road)
Updates
  • Resolved
    Resolved

    This incident has been resolved. Both Heaton Road and Walworth Rd (Elephant & Castle) branches have re-opened, and our phone helpdesk service is now running as usual.

    Thank you for your patience, and we apologise for this morning's disruption.

  • Investigating
    Investigating

    Due to an issue affecting the systems that our staff use to serve members, our branches are closed this morning. Our phone helpdesk is open, but staff may be unable to help with transaction or account-related queries.

    Online banking services, including the mobile app, are unaffected and you will be able to log in as normal. If you cannot use online banking and your query is not urgent, please consider emailing us or submitting a help request and we will respond as soon as normal service is restored.

    This disruption is expected to last at least until midday. We hope to be able to re-open branches this afternoon and will update here when we are able to do so.

    Thank you for your patience and understanding. We will update here as soon as this issue is resolved.