Payments & Transfers experiencing partial outage

Phone Support Degraded

Resolved
Operational
Started about 1 month ago Lasted about 5 hours

Affected

Phone Support
Email Support
Updates
  • Resolved
    Resolved

    All services have now been restored, and our phone helpdesk will now be running as normal from 2:30pm until our normal closing time of 5:00pm. However, lines may be busy, so please consider emailing if your call is not urgent. Thank you again for your patience and understanding.

  • Identified
    Identified

    Due to a systems issue, our phone helpdesk team may be unable to help with calls about your account or transactional-related queries this morning. The phone line remains open, but helpdesk staff may be unable to help immediately.

    Online banking services, including the mobile app are unaffected. If you cannot use online banking and your query is not urgent, please consider emailing us or submitting a help request via https://support.creditunion.co.uk/ and we will respond as soon as normal service is restored.

    Thank you for your patience and understanding. We will update here as soon as regular service is restored.