Payments & Transfers experiencing partial outage

Balance Update SMS Outage

Resolved
Operational
Started over 1 year ago Lasted 3 months

Affected

Mobile App
Online Banking
SMS Services
Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently working on fixing an issue in online banking and SMS Bal for current account members. Balances are currently not reflecting some pending transactions. We are working on fixing this issue on priority but in the meantime, our balance update SMS service will not be available.
    We apologise for any inconvenience this may cause and aim to resolve this issue as soon as we can.