Payments & Transfers experiencing partial outage

Account information Unavailable in Online Banking & Mobile Apps

Resolved
Partial outage
Started over 1 year ago Lasted 32 minutes

Affected

Mobile App
Online Banking
Updates
  • Resolved
    Resolved

    This issue is now resolved. Details of your accounts should now be displaying correctly in online and mobile banking, and any delayed incoming or outbound payments will now be actioned.

    If you continue to experience difficulties, please email us at help@creditunion.co.uk and a member of the team will be happy to assist you.

    Thank you for your patience during this morning's disruption.

  • Identified
    Identified

    We are experiencing a temporary issue which is preventing details of your accounts from being displayed in online banking or our mobile app. We apologise for the inconvenience this will cause.

    We expect this issue to be fixed within the next 30-90 minutes and will update here when the issue is resolved.