Payments & Transfers experiencing partial outage

System Outage

Resolved
Partial outage
Started over 1 year ago Lasted 1 day

Affected

Payments & Transfers
Mobile App
Online Banking
Updates
  • Resolved
    Update

    We just resolved the issue!

  • Resolved
    Resolved

    We apologies for any inconvenience our outage may have caused. This issue has now been resolved!

  • Identified
    Identified

    Payments and transfers have been restored since our earlier incident on Friday 23rd September and we are working to restore our online banking service on priority.
    We apologize for any inconvenience this may have caused and we will continue to update you with our progress.

  • Investigating
    Investigating

    Due to unforeseen circumstances our Online and Mobile Banking Services are currently down. Whilst we work on this issue, our branches will be operating a limited service. We have been made aware that payments and transfers have also been affected and are looking into this on priority. We apologize for any inconvenience this may cause and will update this page once the issue has been resolved.