Experiencing issues

[Resolved] Walworth Road Branch - Early Closing

Started on 1 November, 2021 at 4:00 PM. Resolved after 30 minutes

Affected

Branches
Walworth Road
  • Identified
    1 November, 2021 at 4:00 PM

    Our Walworth Rd branch will be closing 30 minutes early today at 4:00pm due to staff availability. We hope to resume normal opening hours from tomorrow.

  • Resolved
    1 November, 2021 at 4:30 PM

    Walworth Road Branch is now open as usual