Experiencing issues

[Resolved] National Insurance Number Validation

Started on 6 September, 2021 at 8:53 AM. Resolved after 11 days

Affected

Loan & Membership Application Processing
  • Identified
    6 September, 2021 at 8:53 AM

    We are aware of an issue where some loan applicants are unable to enter their national insurance number when applying for a loan.

    You may be able to work around this by copy and pasting the number into the form, or by entering it without dashes or spaces. We are currently in the process of implementing a fix. Thank you for your patience.

  • Resolved
    16 September, 2021 at 8:53 PM

    We have implemented a fix to this issue, which affected iPhone 7 users and earlier. It should now be possible for these users to complete the application form.