London Mutual Credit Union - Temporary Disruption to Helpdesk, Branch Services and Card Payments – Incident details

All systems operational

Temporary Disruption to Helpdesk, Branch Services and Card Payments

Resolved
Operational
Started 5 days agoLasted about 1 hour

Affected

Payments & Transfers

Major outage from 2:57 PM to 3:51 PM

Mobile App

Major outage from 2:57 PM to 3:51 PM

Online Banking

Major outage from 2:57 PM to 3:51 PM

SMS Services

Major outage from 2:57 PM to 3:51 PM

Phone Support

Major outage from 2:57 PM to 3:51 PM

Walworth Road Branch

Major outage from 2:57 PM to 3:51 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We’re currently experiencing a technical issue affecting our card transactions and online banking systems.  For our current account card holders, during this time, you will be able to withdraw up to £50 from an ATM machine. 

    Our Mobile Banking App and access to Online Banking have been frozen until the time the issue is resolved.

    You can still call us or visit a branch, but it is possible that our team will be unable to help for now, and will ask you to call back later.

    We apologise for the disruption today, and thank you for your patience. We will continue to post updates here, including when the issue is resolved.