Payments & Transfers experiencing partial outage

Walworth Road Branch is Temporarily Closed

Resolved
Operational
Started 29 days ago Lasted about 6 hours

Affected

Walworth Road Branch
Updates
  • Resolved
    Resolved

    All services have now been restored, and this branch will be open from 3:00pm until its normal closing time of 4:30pm today. Thank you again for your patience and understanding.

  • Investigating
    Investigating

    Our Walworth Rd (Elephant & Castle) branch is closed this morning due to a systems issue. We are working to resolve this problem, and hope to be able to re-open later today. We will update here as soon as the branch has re-opened.