Payments & Transfers experiencing partial outage

Peckham Branch is Temporarily Closed

Resolved
Major outage
Started about 1 month ago Lasted 1 day

Affected

Peckham Branch (Heaton Road)
Updates
  • Resolved
    Resolved

    All services have now been restored, and this branch will be open from 3:00pm until its normal closing time of 4:30pm today. Thank you again for your patience and understanding.

  • Identified
    Update

    Peckham branch is closed this morning, 3 April. Subject to sufficient staff availability, we hope to be able to open this branch later today. We will confirm here once we are able to do so.

  • Identified
    Identified

    We regret to inform you that our Peckham branch will be closed on Tuesday, April 2nd, due to unforeseen sickness. We apologize for any inconvenience this may cause and appreciate your understanding. Please feel free to visit our Walworth Road branch for assistance, or reach out to us via email or phone for any urgent inquiries. Thank you for your patience and continued support.