All systems operational

Duplicated monthly current account fees

Resolved
Operational
Started about 2 months ago Lasted less than a minute

Affected

Payments & Transfers
Updates
  • Resolved
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    We hope this message finds you well. We want to bring to your attention a recent issue regarding duplicated monthly current account fees that may have been charged to your account.

     

    Please be assured that we are fully aware of this situation, and our team is working to resolve it promptly. We understand the inconvenience this may have caused, and we sincerely apologize for any confusion or frustration it may have generated.

     

    Our top priority is to ensure that your account is rectified and any erroneously charged fees are refunded as soon as possible. We appreciate your patience and understanding as we work diligently to fix this matter.

    Any new information on this matter will be updated.