London Mutual Credit Union - Call wait times longer than usual – Incident details

All systems operational

Call wait times longer than usual

Resolved
Major outage
Started about 2 years agoLasted 4 days

Affected

Phone Support

Major outage from 9:01 AM to 11:12 AM

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    Due to staff shortages, our phone waiting time will take longer than usual. Please email us at help@creditunion.co.uk for non-urgent queries. Sorry for any inconvenience caused.

  • Investigating
    Investigating

    Due to staff shortages, the wait time for our phone line is longer than usual. Sorry for any inconvenience caused. Please email us at help@creditunion.co.uk for non-urgent queries.