London Mutual Credit Union - Brixton Branch Closed – Incident details

All systems operational

Brixton Branch Closed

Resolved
Minor outage
Started over 2 years agoLasted 4 days

Affected

Updates
  • Resolved
    Resolved

    All branches are open as usual.

  • Investigating
    Investigating

    Our Brixton branch (10 Acre Lane) will be closed on Thursday 31st March and Friday 1st April due to staff shortages. We're sorry for any inconvenience caused.

    Please continue to use our two other branches in Peckham and Walworth Road.