London Mutual Credit Union - Brixton Branch Closed – Incident details

All systems operational

Brixton Branch Closed

Resolved
Operational
Started over 2 years agoLasted 1 day

Affected

Updates
  • Resolved
    Resolved

    Brixton branch is open as usual.

  • Investigating
    Investigating

    Our branch (10 Acre Lane) in Brixton is currently closed due to staff shortages, we hope to be back open as soon as possible. Our branches in Peckham and Walworth Road are open as usual.

    Sorry for any inconvenience caused.