London Mutual Credit Union - All branches closing early – Incident details

All systems operational

All branches closing early

Resolved
Operational
Started over 2 years agoLasted 3 days

Affected

Walworth Road Branch

Operational from 11:53 AM to 9:48 AM

Peckham Branch (Heaton Road)

Operational from 11:53 AM to 9:48 AM

Updates
  • Resolved
    Resolved

    All branches are open as usual.

  • Investigating
    Investigating

    All 3 of our branches will be closing at 3:30pm today due to the weather conditions. We're sorry for any inconvenience caused.