London Mutual Credit Union - Brixton Branch Closed – Incident details

All systems operational

Brixton Branch Closed

Resolved
Major outage
Started over 2 years agoLasted 13 days

Affected

Updates
  • Resolved
    Resolved

    We just resolved the issue!

  • Identified
    Identified

    Due to a shortage of staff our Brixton branch will remain closed until further notice. Our Peckham and Walworth branches remain open.

    Sorry for any inconvenience.

  • Investigating
    Investigating

    Our branch in Brixton (Acre Lane) will be closed from 22/12/21 due to the availability of staff. This closure is temporary, and we expect to re-open on 29th December.

    Our branches in Peckham (4 Heaton Rd) and 177 Walworth Rd remain open as usual.