London Mutual Credit Union - Phone Helpdesk (02037731751) Unavailable – Incident details

All systems operational

Phone Helpdesk (02037731751) Unavailable

Resolved
Operational
Started 4 months agoLasted 32 minutes

Affected

Phone Support

Major outage from 11:10 AM to 11:41 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Our main line number 02037731751 is currently unavailable due to a widespread Amazon Web Services (AWS) outage on October 20-21, 2025, which impacted many services reliant on the cloud provider.

     

    In the meantime, if you need immediate assistance, please email us at help@creditunion.co.uk or send a secure message via Online Banking, and we will respond to your enquiry as quickly as possible.

    We apologise for any inconvenience and appreciate your patience.